What is the logic behind PO Change Orders?
Tracking Changes to Purchase Order
Solution ID = KB-358
Goal : Change Status is F for PO change order that has [PO 22750} and [change 1].
Version = All Version
Module : SLCOPO
Symptom 1 : Error: Should [Create PO Change Order] be performed?
Symptom 2 : Error: Should [Update Open PO Change Order] performed?
Database : Progress, SQL
Cause
Once the status of a
Fix
THE PARAMETER
A flag on the Purchasing Parameters
screen controls one of three ways to deal with Change Orders:
N = Never: use this option if you
never want to use PO Change Orders. You will never see any questions or
references to PO Change Orders.
A = Always: use this option if you
always want to use Po Change Orders. You will not see any questions asking you
to create a Change order. The system will assume that every update to an
Ordered PO will cause a
S = Sometimes: use this option if
you want some PO maintenance to create PO Change Orders yet still be allowed to
do some maintenance without having to create Change Orders. When S is chosen,
you will be asked a question every time you do any maintenance on an Ordered
PO. The question will ask you if you want this particular change to be a PO
Change Order.
THE
On the Purchase Order screen, the PO
Change Number and the PO Change Status were added. In order to make these field
fit, Print Price was moved to Purchase Orders-Page 2. These two new fields are
both DISPLAY only on this screen. The change number and its status were put on
this screen to allow the user to quickly identify whether there were changes
for a particular
THE
The PO Change Orders screen is
located off Purchase Orders from the Views menu using C-PO Change Orders. It
displays the change order text for all
The Change Order status can be one
of three values:
O= Open- this indicated it is an
open change order. When a change order is originally created, the status
defaults to Open. If you do several different updates to a
F= Final- Once all changes for a
specific Change Order are complete, you should change the status of that change
order to "F". This indicates you are done making changes for this
Change order and are ready for it to be printed. The system still considers
this change order outstanding until it is actually printed. There can only be
one outstanding Change Order (status = O or F) for a
A change Order is a document that
looks just like the Purchase Order and it is the document used to communicate
the changes to the vendor. The change order option screen is very similar to
the
Chg status:
Print Entire
Change orders can be printed for any
When a change order is printed, you
are given the option to print the Entire PO or only printed the changes. If you
say print entire PO all lines for that PO will display on the change order and
it will look just like the
The report will print data from the
"real" PO files thus displaying the most recent data for a given
Note
THE
From the PO Change Order view, there
are two list options available. P-PO Change Orders
L-Line/Release Change Detail
The P-PO Change Order list displays all the change orders in
The L-Line/Release Change Detail list displays the detail information for each change order. It displays what line were changed, added or deleted; and if the header was changed. The list is meant to be a simple indication of what changes were made., This list only reports on old and new values for CERTAIN KEY fields. If the user wants the complete detail on all the fields changed for a particular change order, they should run the Change Order Detail report. This list only reports old and new values for the following fields: VENDOR, ITEM, SHIP VIA TERMS QTY ORDERED, ITEM COST and DUE DATE.
HOW
Change Orders are created
"behind the scenes" in a matter of speaking. Change Orders are
created during normal
If the system parameter is set to
(S)ometimes, this means that some update to an Ordered PO should trigger a
Change Order while other updates should not. Therefore, the system will ask a
questions during the update to an Ordered PO. If there are no prior change
orders for this
This simply means that a new change
order is being created for this
If there already is an Open Change
Order for that
A Yes to this question means the
changed will be added into the existing change order. If you answer no to this
question, you are telling the system you do not wish to trigger a change order
for this particular update.
If the system parameter is set to
(A)lways, the system will assume EVERY update and EVERY add to an Ordered PO
will trigger a PO Change Order. The user will not be asked if they want to
create a Po Change Order, not will they be able to stop them from being created
for a specific update. If there already is a change order for a particular PO
and the user does an update to that
If the status is (P)rinted, then a
new Po Change Order will be created for that
If the status is (F)inal, then
updates will not be allowed until the user changes that status to
"P", prints the Change Order which causes the status of that change
order to get change to "P" or reopens the Change Order by changing
the status to (O)pen.
During the update process, if you
choose to create a Change Order, you will be taken into Change Order text
automatically. Change Orders do not require that the user add text, but the
system makes it easier for a user to add the change order text, by bringing the
user into the text screen automatically.
After you are satisfied that all the
changes are entered for a particular Change Order, you could go to the Change
Order view and change the status of the change order to (F)inal. Now the change
order is ready to be printed. You can choose to immediately print the change
order by going to the Change Order report on the reports menu and printing this
Change Order, or wait until a few change orders queue up and pint a batch of
them together.