SL 8 Administrative Client errors upon save of a record
Solution ID = KB-57
Goal : SL 8 Administrative Client errors upon save of a record
Version = Syteline8.00.10
Module : SLTECH
Fact 1 : SL 8 Administrative Client
Fact 2 : MSDTC
Symptom 1 : Network access for Distributed Transaction Manager (MSDTC) has been disabled. Please enable DTC for network access in the security configuration for MSDTC using the Component Services Administration tool.
Symptom 2 : Communication with the underlying transaction manager has failed.
Cause
Local Client Firewall is by default blocking MSDTCWindows Event Viewer Application Log Entry:
The COM+ Event System failed to create an instance of the subscriber partition:{41E90F3E-56C1-4633-81C3-6E8BAC8BDD70}!new:{6295DF2D-35EE-11D1-8707-00C04FD93327}. CoGetObject returned HRESULT 8000401A
Fix
Adjust the MSDTC settings on the Client, Utility Server and Database Server
- Go to Start>Settings>Control Panel>Administrative Tools>Component Services
- Expand Component Services until you find 'My Computer'
- Right click on 'My Computer' and select Properties
- On Default Properties Tab:
- Select 'Enable Distributed COM on this Computer'
- Verify that the 'Default Authentication Level' is set to 'Connect'
- Verify that the 'Default Impersonation Level' is set to 'Identify'
- Select the MSDTC Tab:
- Click the 'Security Configuration' button
- On the Security Configuration menu:
- Select Network DTC Access
- Select the Transaction Manager Communication options 'Allow Inbound' and 'Allow Outbound'
- Select 'Mutual Authentication Required' (if not using clustered servers)
- If using clustered servers choose: Incoming Caller (see below for note on clustering
- Click OK
- Click OK
If you are geetting this error:
Network access for Distributed Transaction Manager (MSDTC) has been
disabled. Please enable DTC for network access in the security
configuration for MSDTC using the Component Services Administration
tool.
The transaction manager has disabled its support for remote/network transactions. (Exception from HRESULT: (0x8004D024)
Modify the Windows Firewall, exception list to include MS DTC (Windows\System32\msdtc.exe